> ### 留言板 ![](https://box.kancloud.cn/2c5053937f941535eed301095a172d56_1362x773.png) > ### Html模板 - Html模板留言板下载:[1.6 留言板源码下载](1.6数组排序.md) > ### 原生PHP * 原生PHP留言板下载:[1.6 留言板源码下载](1.6数组排序.md) ```php //messagebox/includes/main.inc.php //留言板运行时只能require_once其中一个, 另外两个注释掉 //require_once(__SITE_ROOT . '/includes/mysql.lib.php'); //需要mysql扩展 PHP运行环境 < 7 (PHP7已移除MySQL扩展) require_once(__SITE_ROOT . '/includes/mysqli.lib.php'); //需要mysqli扩展 (PHP7不建议使用) //require_once(__SITE_ROOT . '/includes/pdo.lib.php'); //需要pdo扩展 ``` > ### ThinkPHP5 - ThinkPHP5留言板源码下载: [1.6 留言板源码下载](1.6数组排序.md) > ### Go原生模板渲染 + Gin APi框架 - Go原生模板渲染 + Gin APi框架留言板源码下载: [1.6 留言板源码下载](1.6数组排序.md) > ### NodeJs(Express框架pug模板引擎) - NodeJs吃饭统计源码下载: [1.6 留言板源码下载](1.6数组排序.md)