# 拓扑图
![](https://box.kancloud.cn/7b8969215effa8f3270b47faee328985_707x478.jpg)
# 基础配置
## MS1:
~~~
Switch>enable //进入特权模式
Switch#configure terminal //进入全局配置模式
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#hostname MS1 //修改主机名为MS1
MS1(config)#vlan 10 //创建 vlan 10
MS1(config-vlan)#name vlan192 //vlan 10 命名为 vlan192
MS1(config)#vlan 20 //创建 vlan 20
MS1(config-vlan)#name vlan172 //vlan 20 命名为 vlan172
MS1(config)#interface fastEthernet 0/1 //进入 f0/1 接口配置模式
MS1(config-if)#switchport mode access //设置接口为 access 模式
MS1(config-if)#switchport access vlan 10 //把接口划分到 vlan 10
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan10, changed state to up
MS1(config)#interface fastEthernet 0/2 //进入 f0/2 接口配置模式
MS1(config-if)#switchport mode access //设置接口为 access 模式
MS1(config-if)#switchport access vlan 20 //把接口划分到 vlan 10
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan10, changed state to up
MS1(config)#interface vlan 10 //进入 vlan 10 接口配置模式
%LINK-5-CHANGED: Interface Vlan10, changed state to up
MS1(config-if)#ip address 192.168.1.254 255.255.255.0 //配置 ip 地址(网关)
MS1(config)#interface vlan 20 //进入 vlan 20 接口配置模式
%LINK-5-CHANGED: Interface Vlan10, changed state to up
MS1(config-if)#ip address 172.16.1.254 255.255.255.0 //配置 ip 地址(网关)
MS1(config)#ip routing //开启路由功能
~~~
## PC 0:
![](https://box.kancloud.cn/15b14fbcb518c356479608a180971dec_646x568.jpg)
## PC 1:
![](https://box.kancloud.cn/9600445c1272495626adbb165898d620_644x567.jpg)
# 实验测试
通过 ping 测试连通性
* PC 0 与 PC 1 之间可以通信(不同 vlan)