~~~
# A + B Problem II
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 273307 Accepted Submission(s): 52784
~~~
Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
Sample Input
~~~
2
1 2
112233445566778899 998877665544332211
~~~
Sample Output
~~~
Case 1:
1 + 2 = 3
Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110
~~~
~~~
import java.math.BigDecimal;
import java.util.Scanner;
// 代码提交时改为Main且去掉当前文件的包名
public class Main {
public static void main(String[] args) {
/**
* 从题目中可以看出来,数据比较大,只是用普通的整形或者别的恐怕是无能为力,不过BigDecimal对于数据较大的数处理十分的方便
* 而且封装好了函数只需要调用就可以了
*/
Scanner scanner = new Scanner(System.in);
int num = scanner.nextInt();
// 这里的二维数组也需要有些讲究,一般一行中查找不同的列的速度要比一列中查找不同的行的数据要快
BigDecimal[][] bigNum = new BigDecimal[num][2];
for(int i = 0; i < num; i++)
{
bigNum[i][0] = scanner.nextBigDecimal();
bigNum[i][1] = scanner.nextBigDecimal();
}
// 输出的时候注意空格,以及的空行
for(int j = 0; j < num; j++)
{
if(j != 0)
System.out.println();
System.out.println("Case "+(j+1)+":");
System.out.println(bigNum[j][0] +" + "+ bigNum[j][1]+" = "+ bigNum[j][0].add(bigNum[j][1]));
}
}
}
~~~
- 前言
- 求和的问题ACM
- A+B问题acm
- 1091ACM求和
- 杭电ACM1092求和问题详解
- ACM杭电的1093求和问题
- 杭电ACM1094计算A+B的问题
- 杭电ACM1095解决A+B问题
- 杭电ACM1096求和问题
- 杭电Acm1001解决求和的问题
- 杭电ACM1008电梯问题C++
- 杭电ACM大赛2000关于ASCII码排序的问题
- 杭电ACM2006奇数的乘积
- 杭电ACM数值统计2008
- 杭电ACM1019求最大公约数
- 杭电ACM1108求最小公倍数
- 杭电ACM2035人见人爱的A^B
- 杭电ACM1061N^N求最右边的数的问题
- 杭电ACM1021裴波纳挈数AGAIN
- 杭电ACm1005求f(n)非递归
- 杭电ACM1071The area---------求积分面积
- 杭电ACM吃糖果问题
- 杭电ACm求数列的和2009
- 杭电ACM多项式求和--》2011
- 杭电ACM。。。sort
- 杭电ACM1004
- 杭电ACM2043密码的问题已经AC
- 杭电ACM2041楼梯问题
- 动态规划C++::杭电ACM1003
- 杭电ACM----2018母牛的故事
- 杭电ACM2007平方和与立方和
- 卢卡斯队列
- 全国软件2. 三人年龄
- 全国软件3. 考察团组成
- 全国软件--微生物增殖
- 全国软件填写算式
- 全国软件-----------猜生日
- 全国软件---------欧拉与鸡蛋
- Java经典算法四十例编程详解+程序实例
- 杭电ACMA + B Problem II问题解析
- 杭电ACM1018BigNumber解析
- 杭电ACM1088 Write a simple HTML Browser Java
- 杭电ACM1106排序Java代码
- 杭电ACM 1012 u Calculate e java
- 杭电ACM 1020 Encoding java解析
- 杭电1047 An Easy Task - java 解读
- 杭电ACM 1040 As Easy As A+B java 解读
- 杭电ACM 1041 Computer Transformation java代码详解AC
- 杭电ACM 1030 Delta-wave java代码解析