~~~
# Encoding
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 34681 Accepted Submission(s): 15377
~~~
Problem Description
Given a string containing only 'A' - 'Z', we could encode it using the following method:
1. Each sub-string containing k same characters should be encoded to "kX" where "X" is the only character in this sub-string.
2. If the length of the sub-string is 1, '1' should be ignored.
Input
The first line contains an integer N (1 <= N <= 100) which indicates the number of test cases. The next N lines contain N strings. Each string consists of only 'A' - 'Z' and the length is less than 10000.
Output
For each test case, output the encoded string in a line.
Sample Input
~~~
2
ABC
ABBCCC
~~~
Sample Output
ABC
A2B3C解题思路整理:对字符串进行遍历,如果当前的字符与前面的字符相同的话那么我加1记录其个数,如果不相同的时候,排除只有1个的情况,只有在字符重复个数大于1的时候那么认为是有多个在一起,这是将字符串拼接组成新的串继续下一步操作。
~~~
import java.util.ArrayList;
import java.util.List;
import java.util.Scanner;
public class Main {
public static void main(String[] args) {
Scanner scanner = new Scanner(System.in);
int count = scanner.nextInt();
int i = 0, countNum = 0, j = 0, j2 = 0;
String str ;
String str2 = "";
char sCopy = 0;
List<String> list = new ArrayList<String>();
while(i < count)
{
str = scanner.next();
sCopy = 0;
j = 0;
str2 = "";
countNum = 0;
while(j < str.length())
{
if(sCopy != str.charAt(j))
{
if(countNum > 1)
{
str2 = str2 + countNum + sCopy;
}
else if(j != 0)
str2 = str2 + sCopy;
countNum = 0;
sCopy = str.charAt(j);
}
if(sCopy == str.charAt(j))
{
countNum++;
}
j++;
if(j == str.length())
{
if(countNum > 1)
{
str2 = str2 + countNum + sCopy;
}
else if(j != 0)
str2 = str2 + sCopy;
list.add(str2);
}
}
i++;
}
for(i = 0; i < count; i++)
{
System.out.println(list.get(i));
}
}
}
~~~
- 前言
- 求和的问题ACM
- A+B问题acm
- 1091ACM求和
- 杭电ACM1092求和问题详解
- ACM杭电的1093求和问题
- 杭电ACM1094计算A+B的问题
- 杭电ACM1095解决A+B问题
- 杭电ACM1096求和问题
- 杭电Acm1001解决求和的问题
- 杭电ACM1008电梯问题C++
- 杭电ACM大赛2000关于ASCII码排序的问题
- 杭电ACM2006奇数的乘积
- 杭电ACM数值统计2008
- 杭电ACM1019求最大公约数
- 杭电ACM1108求最小公倍数
- 杭电ACM2035人见人爱的A^B
- 杭电ACM1061N^N求最右边的数的问题
- 杭电ACM1021裴波纳挈数AGAIN
- 杭电ACm1005求f(n)非递归
- 杭电ACM1071The area---------求积分面积
- 杭电ACM吃糖果问题
- 杭电ACm求数列的和2009
- 杭电ACM多项式求和--》2011
- 杭电ACM。。。sort
- 杭电ACM1004
- 杭电ACM2043密码的问题已经AC
- 杭电ACM2041楼梯问题
- 动态规划C++::杭电ACM1003
- 杭电ACM----2018母牛的故事
- 杭电ACM2007平方和与立方和
- 卢卡斯队列
- 全国软件2. 三人年龄
- 全国软件3. 考察团组成
- 全国软件--微生物增殖
- 全国软件填写算式
- 全国软件-----------猜生日
- 全国软件---------欧拉与鸡蛋
- Java经典算法四十例编程详解+程序实例
- 杭电ACMA + B Problem II问题解析
- 杭电ACM1018BigNumber解析
- 杭电ACM1088 Write a simple HTML Browser Java
- 杭电ACM1106排序Java代码
- 杭电ACM 1012 u Calculate e java
- 杭电ACM 1020 Encoding java解析
- 杭电1047 An Easy Task - java 解读
- 杭电ACM 1040 As Easy As A+B java 解读
- 杭电ACM 1041 Computer Transformation java代码详解AC
- 杭电ACM 1030 Delta-wave java代码解析