[TOC]
### 题目描述
1054. 求平均值 (20)
本题的基本要求非常简单:给定N个实数,计算它们的平均值。但复杂的是有些输入数据可能是非法的。一个“合法”的输入是[-1000,1000]区间内的实数,并且最多精确到小数点后2位。当你计算平均值的时候,不能把那些非法的数据算在内。
输入格式:
输入第一行给出正整数N(<=100)。随后一行给出N个正整数,数字间以一个空格分隔。
输出格式:
对每个非法输入,在一行中输出“ERROR: X is not a legal number”,其中X是输入。最后在一行中输出结果:“The average of K numbers is Y”,其中K是合法输入的个数,Y是它们的平均值,精确到小数点后2位。如果平均值无法计算,则用“Undefined”替换Y。如果K为1,则输出“The average of 1 number is Y”。
输入样例1:
7
5 -3.2 aaa 9999 2.3.4 7.123 2.35
输出样例1:
ERROR: aaa is not a legal number
ERROR: 9999 is not a legal number
ERROR: 2.3.4 is not a legal number
ERROR: 7.123 is not a legal number
The average of 3 numbers is 1.38
输入样例2:
2
aaa -9999
输出样例2:
ERROR: aaa is not a legal number
ERROR: -9999 is not a legal number
The average of 0 numbers is Undefined
### 分析(伪代码和知识点)
### 代码
```
#include<stdio.h>
#include<stdlib.h>
#define DOT 1
#define SIGN 2
#define INT 4
#define FLOAT 8
#define LARGE 16
int check(char *buf)
{
int flag=0,i,count,temp;
char dot;
for(i=0;buf[i];i++)
{
switch(buf[i])
{
case '.':
if(flag&DOT)
{
return 0;
}
else
{
flag=flag|DOT;
}
break;
case '+':
case '-':
if(flag&SIGN||flag&DOT)
{
return 0;
}
else
{
flag=flag|SIGN;
}
break;
default:
if(!(buf[i]>='0'&&buf[i]<='9'))
{
return 0;
}
}
}
for(i=0;buf[i]!='.'&&buf[i]!=0;i++)
{
;
}
count=0;
for(i;buf[i];i++)
{
count++;
}
if(count>3)
{
return 0;
}
return 1;
/* for(i=0;buf[i]!='.'&&buf[i]!=0;i++)
{
;
}
dot=buf[i];
buf[i]=0;
sscanf(buf,"%d",&temp);
buf[i]=dot;
if(temp>1000||temp<-1000)
{
return 0;
}
if(buf[i]==0)
{
return 1;
}
if(temp==1000||temp==-1000)
{
flag=flag|LARGE;
}
temp=0;
buf[i]='0';
sscanf(buf+i,"%d",&temp);
buf[i]=dot;
count=0;
for(i++;buf[i];i++)
{
count++;
}
if(count>2)
{
return 0;
}
if((flag&LARGE)&&temp==0||temp<100&&(flag&LARGE)==0)
{
return 1;
}
else
{
return 0;
}*/
}
int main()
{
int n,i,total=0;
double sum=0,temp;
char buf[101];
scanf("%d",&n);
for(i=0;i<n;i++)
{
scanf("%s",buf);
if(check(buf))
{
sscanf(buf,"%lf",&temp);
if(temp<=1000.00&&temp>=-1000.00)
{
sum+=temp;
total++;
}
else
{
printf("ERROR: %s is not a legal number\n",buf);
}
}
else
{
printf("ERROR: %s is not a legal number\n",buf);
}
}
if(total==0)
{
printf("The average of 0 numbers is Undefined\n");
}
else if(total==1)
{
printf("The average of %d number is %.2lf\n",total,sum);
}
else
{
printf("The average of %d numbers is %.2lf\n",total,sum/total);
}
}
```
- 大赛说明
- PAT乙集题库
- 模板
- 1001.害死人的3n+1 c
- 1002.写出这个数 c 02
- 1003.我要通过(20)c03
- 1004.成绩排名 C 04
- 1005.继续(3n+1)猜想 (25) c05
- 1006. 换个格式输出整数 (15) c06
- 1007.素数对猜想 (20) C 07
- 1008. 数组元素循环右移问题 (20) c08
- 1009.说反话(20)c09
- 1010.一元多项式求导 (25) c10
- 1011. A+B和C(15)c11
- 1012.数字分类 C12
- 1013.数素数(20) C 13
- 1014.福尔摩斯的约会(20)c 14
- 1015.德才论c15
- 1016.部分A+B C 16
- 1018.锤子剪刀布c18
- 1023 组个最小数(20) C23
- 1024 科学计数法(20) C24
- 1025.反转链表(25)C25
- 1026.程序运行时间(15)c 26
- 1027. 打印沙漏(20) C 27
- 1028 人口普查(20) C 01
- 1029. 旧键盘(20) C 01
- 1030.完美数列 C 04
- 1031. 查验身份证(15) c05
- 1032. 挖掘机技术哪家强(20) c06
- 1033. 旧键盘打字(20) C 07
- 1034. 有理数四则运算 08
- 1035.插入和归并 C 09
- 1036.跟奥巴马一起编程(15)C18
- 1037.在霍格沃茨找零钱C 11
- 1039.到底买不买 C 13
- 1041.考试座位号(15)C03
- 1042。字符统计 C16
- 1044.火星数字 C 15
- 1046. 划拳(15) C 01
- 1047.编程团体赛C18
- 1051.复数乘法(15) c24
- 1054. 求平均值 (20) C
- 1036. 跟奥巴马一起编程(15) c10
- 1055.集体照 C 09
- 1050. 螺旋矩阵
- C语言
- assert.h
- stdio.h
- Operations on files
- File access
- Formatted input/output
- Character input/output
- Direct input/output
- File positioning
- Error-handling
- Macros
- 数据结构
- 算法
- 5月8日测试题目
- 乔栋
- 01申彦栋
- 02方常吉
- 03王永明
- 04刘果静
- 05原晓晓
- 09牛锦江
- 10李泽路
- 11葛建辉
- 12程才耀
- 13王旭昕
- 16田鹏
- 15李新奇
- 24王翡
- 18高捷
- 07耿生年
- 05王进
- 25闫鑫炎
- 5月9日测试题目
- 热身题库
- L1-1
- L1-2
- L1-3
- L1-4
- L1-5
- L1-6
- L1-8
- L1-7
- L2-1
- L2-2
- L2-3
- L2-4
- L3-1
- L3-2
- L3-3