25
###原题描述
题要求将给定的N个正整数按非递增的顺序,填入“螺旋矩阵”。所谓“螺旋矩阵”,是指从左上角第1个格子开始,按顺时针螺旋方向填充。要求矩阵的规模为m行n列,满足条件:m*n等于N;m>=n;且m-n取所有可能值中的最小值。
输入格式:
输入在第1行中给出一个正整数N,第2行给出N个待填充的正整数。所有数字不超过104,相邻数字以空格分隔。
输出格式:
输出螺旋矩阵。每行n个数字,共m行。相邻数字以1个空格分隔,行末不得有多余空格。
输入样例:
12
37 76 20 98 76 42 53 95 60 81 58 93
输出样例:
98 95 93
42 37 81
53 20 76
58 60 76
###代码
~~~
#include<stdio.h>
#include<stdlib.h>
int *buf,**matrix,guide=0,m,n,N;
struct position
{
int x;
int y;
} filler={0,0},direction[4]={{1,0},{0,1},{-1,0},{0,-1}};
int rcompare(const void *a,const void *b)
{
return *(int *)b-*(int *)a;
}
int canmove()
{
int x,y;
x=filler.x+direction[guide].x;
y=filler.y+direction[guide].y;
if(x<0||x>=n||y<0||y>=m)
{
return 0;
}
else if(matrix[y][x]!=0)
{
return 0;
}
return 1;
}
int move(int count)
{
matrix[filler.y][filler.x]=buf[count];
if(count==N-1)
{
return 0;
}
while(!canmove())
{
guide=(guide+1)%4;
}
filler.y+=direction[guide].y;
filler.x+=direction[guide].x;
return 0;
}
int main()
{
int i,j,count=0;
scanf("%d",&N);
buf=(int *)malloc(N*sizeof(int));
for(i=0;i<N;i++)
{
scanf("%d",buf+i);
}
qsort(buf,N,sizeof(int),rcompare);
m=N;
n=1;
for(i=N;i>0;i--)
{
if(N%i==0)
{
if(i-N/i<0)
{
break;
}
if(i-N/i<m-n)
{
m=i;
n=N/i;
}
}
}
matrix=(int **)malloc(m*sizeof(int *));
for(i=0;i<m;i++)
{
matrix[i]=(int *)calloc(n,sizeof(int));
}
while(count<N)
{
move(count);
count++;
}
for(i=0;i<m;i++)
{
for(j=0;j<n-1;j++)
{
printf("%d ",matrix[i][j]);
}
printf("%d\n",matrix[i][j]);
}
}
~~~
- 大赛说明
- PAT乙集题库
- 模板
- 1001.害死人的3n+1 c
- 1002.写出这个数 c 02
- 1003.我要通过(20)c03
- 1004.成绩排名 C 04
- 1005.继续(3n+1)猜想 (25) c05
- 1006. 换个格式输出整数 (15) c06
- 1007.素数对猜想 (20) C 07
- 1008. 数组元素循环右移问题 (20) c08
- 1009.说反话(20)c09
- 1010.一元多项式求导 (25) c10
- 1011. A+B和C(15)c11
- 1012.数字分类 C12
- 1013.数素数(20) C 13
- 1014.福尔摩斯的约会(20)c 14
- 1015.德才论c15
- 1016.部分A+B C 16
- 1018.锤子剪刀布c18
- 1023 组个最小数(20) C23
- 1024 科学计数法(20) C24
- 1025.反转链表(25)C25
- 1026.程序运行时间(15)c 26
- 1027. 打印沙漏(20) C 27
- 1028 人口普查(20) C 01
- 1029. 旧键盘(20) C 01
- 1030.完美数列 C 04
- 1031. 查验身份证(15) c05
- 1032. 挖掘机技术哪家强(20) c06
- 1033. 旧键盘打字(20) C 07
- 1034. 有理数四则运算 08
- 1035.插入和归并 C 09
- 1036.跟奥巴马一起编程(15)C18
- 1037.在霍格沃茨找零钱C 11
- 1039.到底买不买 C 13
- 1041.考试座位号(15)C03
- 1042。字符统计 C16
- 1044.火星数字 C 15
- 1046. 划拳(15) C 01
- 1047.编程团体赛C18
- 1051.复数乘法(15) c24
- 1054. 求平均值 (20) C
- 1036. 跟奥巴马一起编程(15) c10
- 1055.集体照 C 09
- 1050. 螺旋矩阵
- C语言
- assert.h
- stdio.h
- Operations on files
- File access
- Formatted input/output
- Character input/output
- Direct input/output
- File positioning
- Error-handling
- Macros
- 数据结构
- 算法
- 5月8日测试题目
- 乔栋
- 01申彦栋
- 02方常吉
- 03王永明
- 04刘果静
- 05原晓晓
- 09牛锦江
- 10李泽路
- 11葛建辉
- 12程才耀
- 13王旭昕
- 16田鹏
- 15李新奇
- 24王翡
- 18高捷
- 07耿生年
- 05王进
- 25闫鑫炎
- 5月9日测试题目
- 热身题库
- L1-1
- L1-2
- L1-3
- L1-4
- L1-5
- L1-6
- L1-8
- L1-7
- L2-1
- L2-2
- L2-3
- L2-4
- L3-1
- L3-2
- L3-3